Site news

 
 
Picture of Admin User
Browser Recommendations
by Admin User - Tuesday, October 29, 2013, 10:15 AM
 

myCourses - Recommended Browsers

myCourses will work using the following browsers listed below, but for best results it is recommended to be using the most recent version.

  • Google Chrome 4 or later
  • Mozilla Firefox 10 or later
  • Internet Explorer 10 or later

Note:  You may find it useful to have more than one browser installed on your computer.  If you run in to problems using one, trying another may resolve your issue.

Required Browser Settings

The following browser settings must be selected

  • Cookies enabled
  • Javascript enabled
  • Pop-up blockers disabled (you may also add an exception to mycourses.lsue.edu)